<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
<meta charset="UTF-8"/>
<meta name="viewport" content="width=device-width, initial-scale=1"/>
<meta name="geo.placename" content="Elkin"/>
<meta name="theme-color" content="#1c63b7">
<meta name="geo.region" content="US-NC"/>
<meta name="DC.format" content="text/html" scheme="DCTERMS.IMT"/>
<meta name="DC.relation" content="http://dublincore.org/" scheme="DCTERMS.URI"/>
<meta name="DC.publisher" content="Elkin Tribune"/>
<meta name="DC.contributor" content="Elkin Tribune"/>
<meta name="DC.language" content="en_US" scheme="DCTERMS.RFC3066"/>
<meta name="DC.rights" content="Civitas Media"/>
<meta name="DC.title" content="Elkin Tribune, Elkin NC - www.elkintribune.com"/>
<meta name="DC.description" content=""/>
<meta name="DC.identifier" content="http://elkintribune.com" scheme="DCTERMS.URI"/>
<meta name="DC.type" content="Text" scheme="DCTERMS.DCMIType"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@ElkinTribune"/>
<meta name="twitter:title" content=" - Elkin Tribune - elkintribune.com"/>
<meta name="twitter:description" content=""/>
<meta name="twitter:image" content="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg"/>
<title>The Elkin Tribune | Cheek signs with Methodist University</title>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="The Elkin Tribune &raquo; Feed" href="http://elkintribune.com/feed"/>
<link rel="alternate" type="application/rss+xml" title="The Elkin Tribune &raquo; Comments Feed" href="http://elkintribune.com/comments/feed"/>
<link rel="alternate" type="application/rss+xml" title="The Elkin Tribune &raquo; Cheek signs with Methodist University Comments Feed" href="http://elkintribune.com/sports/college-sports/13343/cheek-signs-with-methodist-university/feed"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/elkintribune.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='paginationstyle-css' href='http://elkintribune.com/wp-content/plugins/faster-pagination/assests/pagination.css' type='text/css' media='all'/>
<link rel='stylesheet' id='simple-staff-list-css' href='http://elkintribune.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css' type='text/css' media='all'/>
<link rel='stylesheet' id='staff-list-custom-css-css' href='http://elkintribune.com/wp-content/themes/civitasmedium/simple-staff-list-custom.css' type='text/css' media='all'/>
<link rel='stylesheet' id='dpsp-frontend-style-css' href='http://elkintribune.com/wp-content/plugins/social-pug/assets/css/style-frontend.css' type='text/css' media='all'/>
<link rel='stylesheet' id='vfb-pro-css' href='http://elkintribune.com/wp-content/plugins/vfb-pro/public/assets/css/vfb-style.min.css' type='text/css' media='all'/>
<link rel='stylesheet' id='noteworthy_style-css' href='http://elkintribune.com/wp-content/themes/civitasmedium/style.css' type='text/css' media='all'/>
<script type='text/javascript' src='http://elkintribune.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-content/plugins/simple-staff-list/public/js/simple-staff-list-public.js?ver=1.17'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-content/plugins/social-pug/assets/js/front-end.js?ver=4.7.3'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-content/themes/civitasmedium/library/js/modernizr-2.6.1.min.js?ver=2.6.1'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-content/themes/civitasmedium/library/js/jquery.nicescroll.js?ver=3.0.0'></script>
<script type='text/javascript' src='http://elkintribune.com/wp-content/themes/civitasmedium/library/js/scripts.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://elkintribune.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://elkintribune.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://elkintribune.com/wp-includes/wlwmanifest.xml"/>
<link rel='prev' title='Buckin&#8217; Elks take MVAC win over Cardinals' href='http://elkintribune.com/sports/high-school-baseball/13341/buckin-elks-take-mvac-win-over-cardinals'/>
<link rel="canonical" href="http://elkintribune.com/sports/college-sports/13343/cheek-signs-with-methodist-university"/>
<link rel='shortlink' href='http://elkintribune.com/?p=13343'/>
<link rel="alternate" type="application/json+oembed" href="http://elkintribune.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Felkintribune.com%2Fsports%2Fcollege-sports%2F13343%2Fcheek-signs-with-methodist-university"/>
<link rel="alternate" type="text/xml+oembed" href="http://elkintribune.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Felkintribune.com%2Fsports%2Fcollege-sports%2F13343%2Fcheek-signs-with-methodist-university&#038;format=xml"/>
<style type="text/css" data-source="Social Pug"></style><meta name="twitter:card" content="summary"/><meta property="og:url" content="http://elkintribune.com/sports/college-sports/13343/cheek-signs-with-methodist-university"/><meta property="og:type" content="article"/><meta property="og:title" content="Cheek signs with Methodist University"/><meta property="og:description" content="One of Elkin&#8217;s standout football players, McKinley Cheek, signed his national letter of intent to"/><meta property="og:image" content="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg"/><style type="text/css">#wpadminbar #wp-admin-bar-vfbp-toolbar-edit-form>.ab-item:before{content:"\f175";top:2px;}#wpadminbar #wp-admin-bar-vfbp-admin-toolbar>.ab-item:before{content:"\f175";top:2px;}</style> <style type="text/css">.recentcomments a{display:inline!important;padding:0!important;margin:0!important;}</style>
<style type="text/css" id="custom-background-css">body.custom-background{background-image:url("http://elkintribune.com/wp-content/themes/civitasmedium/library/images/bg.jpg");background-position:left top;background-size:auto;background-repeat:repeat;background-attachment:scroll;}</style>
<link rel="profile" href="http://gmpg.org/xfn/11"/>
 
<link href='//fonts.googleapis.com/css?family=Roboto:400,700,900' rel='stylesheet' type='text/css'>
<script src="https://code.jquery.com/jquery-2.2.0.min.js" type="text/javascript"></script>
 
<script src="/wp-content/themes/civitasmedium/library/js/slick.js" type="text/javascript" charset="utf-8"></script>
<link rel="stylesheet" type="text/css" href="/wp-content/themes/civitasmedium/library/css/slick.css">
<link rel="stylesheet" type="text/css" href="/wp-content/themes/civitasmedium/library/css/slick-theme.css">
<style type="text/css">.slick-slide{margin:0px;}.slick-prev:before,.slick-next:before{color:white;}</style>
 
<script type="text/javascript" async src="//launch.newsinc.com/js/embed.js" id="_nw2e-js"></script>
<script type="text/javascript">
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-6686294-42']);
						_gaq.push(['_setCustomVar',
			  1, 
			  'Byline',
			  'By Kristian Russell - krussell@civitasmedia.com',     
		   ]);
						_gaq.push(['_trackPageview']);
			(function() {
			 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
			 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
			 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
			})();
		</script>
<script>
		  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
		  ga('create', 'UA-42320030-20', 'civitasmedia.com');
		  ga('send', 'pageview');
		</script>
<script type="text/javascript">
				var _qevents = _qevents || [];
				(function() {
					var elem = document.createElement('script');
					elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
					elem.async = true;
					elem.type = "text/javascript";
					var scpt = document.getElementsByTagName('script')[0];
					scpt.parentNode.insertBefore(elem, scpt);
				})();
				_qevents.push({
					qacct:"p-6dne6PYNkWEck"
				});
			</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-6dne6PYNkWEck.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
 
<script async="async" src="//zdwidget3-bs.sphereup.com/zoomd/SearchUi/Script?clientId=93735767"></script>
 
<style>#content::before{background-color:#1c63b7!important;}#content .item{background-color:#1c63b7!important;}</style>
</head>
<body class="post-template-default single single-post postid-13343 single-format-standard custom-background" style="background-image:url(http://ads.civitasmedia.com/w/1.0/ai?auid=537264036&cs=71d7617044&cb=INSERT_RANDOM_NUMBER_HERE); background-attachment: fixed; background-position: 50% 0%; background-repeat: no-repeat;">
<div id="wrapper">
<header id="branding" role="banner">
<div id="inner-header" class="clearfix" style="margin-bottom:30px;">
<div id="masthead" style="float:left; margin-top:26px;"><h1><a href="/" title="Return to Homepage" style="color:white; font-family:Roboto, Sans Serif;"><img src="http://elkintribune.com/wp-content/uploads/2016/06/elkintribune.png" style="max-width:300px; max-height:50px;"></a>
<br>
<div id="tlclasswidget" style="width:350px;">
<div id="widgetcontent" class="widgetborder">
<a style="color:#ffffff; font-size:15px;" href="http://NCjobs.civitasmedia.com" target="_blank" title="Elkin Tribune Job Match"><span class="glyphicon glyphicon-briefcase"></span>Jobs</a>&nbsp;
<a style="color:#ffffff; font-size:15px;" href="/classifieds" title="Classifieds"><span class="glyphicon glyphicon-briefcase"></span>Classifieds</a>&nbsp;
<a style="color:#ffffff; font-size:15px;" href="https://secure.tecnavia.com/civitas_payments/cv_elkintribune/" target="_blank" title="Subscribe"><span class="glyphicon glyphicon-briefcase"></span>Subscribe</a>&nbsp;
<a style="color:#ffffff; font-size:15px;" href="http://elkintribune.nc.newsmemory.com/" target="_blank" title="E-Edition"><span class="glyphicon glyphicon-briefcase"></span>E-Edition</a>&nbsp;
<a style="color:#ffffff; font-size:15px;" href="http://nccardeals.com" title="Elkin Tribune Autos &amp; Cars"><span class="glyphicon glyphicon-road"></span> Autos</a>&nbsp;
<span style="color:#ffffff; font-size:15px;">Apps:</span>
<a style="color:#ffffff; font-size:15px;" href="https://play.google.cohttps://play.google.com/store/apps/details?id=com.vervewireless.droid.elkintribune&hl=enF890450416186BFF6C7E" target="_blank" title="Android App"> Android</a>&nbsp;
<a style="color:#ffffff; font-size:15px;" href="https://itunes.apple.com/us/app/the-elkin-tribune/id979969555?mt=8" target="_blank" title="Android App">iPhone/iPad</a>&nbsp;
 
</div>
</div>
</div>
<div style="text-align:center; float:left; padding-top:25px; padding-left:10px;">
<script async type="text/javascript"> 
			if (!window.OX_ads) { 
			OX_ads = []; 
			} 
			OX_ads.push({ "auid" : "419628" }); 
			</script>
<script async type="text/javascript"> 
			document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
			</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419628&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="728" height="90">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419628&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
</div>
<nav id="access" role="navigation">
<h1 class="assistive-text section-heading">Main menu</h1>
<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
<div class="menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-6941" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-6941"><a href="http://elkintribune.com">Home</a>
<ul class="sub-menu">
<li id="menu-item-6950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6950"><a href="http://elkintribune.com/about-us">About Us</a></li>
<li id="menu-item-6951" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6951"><a href="http://elkintribune.com/advertise">Advertise</a></li>
<li id="menu-item-6952" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6952"><a href="http://elkintribune.com/contact-us">Contact Us</a></li>
<li id="menu-item-6956" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6956"><a href="https://www.facebook.com/pages/The-Elkin-Tribune/121619696858">Elkin Tribune on Facebook</a></li>
<li id="menu-item-6957" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6957"><a href="http://twitter.com/ElkinTribune">Elkin Tribune on Twitter</a></li>
<li id="menu-item-6953" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6953"><a href="http://elkintribune.com/reader-services">Reader Services</a></li>
<li id="menu-item-6954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6954"><a href="http://elkintribune.com/sign-up-for-notices">Sign Up For Notices</a></li>
<li id="menu-item-6955" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6955"><a href="http://elkintribune.com/subscribe">Subscribe</a></li>
</ul>
</li>
<li id="menu-item-6942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6942"><a href="http://elkintribune.com/category/news">News</a>
<ul class="sub-menu">
<li id="menu-item-6962" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6962"><a href="http://elkintribune.com/archives">Archives</a></li>
<li id="menu-item-6963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6963"><a href="http://elkintribune.com/circulars">Circulars</a></li>
<li id="menu-item-6968" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6968"><a href="http://www.myinvestkit.com/elkintribune.com/">Finance</a></li>
<li id="menu-item-11617" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11617"><a href="http://elkintribune.com/president">President Trump</a></li>
<li id="menu-item-6964" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6964"><a href="http://elkintribune.com/formnewstip">Submit News Tip</a></li>
<li id="menu-item-11382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11382"><a href="http://elkintribune.com/category/special-sections">Special Sections</a></li>
<li id="menu-item-6965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6965"><a href="http://elkintribune.com/online-community">Online Community</a></li>
<li id="menu-item-6966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6966"><a href="http://elkintribune.com/onlineforms">Online Forms</a></li>
<li id="menu-item-6969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6969"><a href="http://elkintribune.com/rss">All Articles Feed</a></li>
</ul>
</li>
<li id="menu-item-6943" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-6943"><a href="http://elkintribune.com/category/sports">Sports</a>
<ul class="sub-menu">
<li id="menu-item-6970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6970"><a href="http://elkintribune.com/formscores">Submit Scores</a></li>
<li id="menu-item-6971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6971"><a href="http://elkintribune.com/formsportsnews">Submit Sports News</a></li>
</ul>
</li>
<li id="menu-item-6949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6949"><a href="http://www.legacy.com/obituaries/elkintribune">Obituaries</a></li>
<li id="menu-item-6945" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6945"><a href="http://elkintribune.com/category/opinion">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-6972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6972"><a href="http://elkintribune.com/formeditor">Submit Letter To The Editor</a></li>
</ul>
</li>
<li id="menu-item-6944" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6944"><a href="http://elkintribune.com/category/features">Features</a>
<ul class="sub-menu">
<li id="menu-item-8118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8118"><a href="http://elkintribune.com/games">Games &#038; Puzzles</a></li>
<li id="menu-item-6973" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6973"><a href="http://elkintribune.com/comics">Comics</a></li>
<li id="menu-item-6974" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6974"><a href="http://elkintribune.com/contests">Contests</a></li>
<li id="menu-item-6975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6975"><a href="http://elkintribune.com/horoscopes">Horoscopes</a></li>
<li id="menu-item-6977" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6977"><a href="http://elkintribune.com/specialsections">Special Sections</a></li>
<li id="menu-item-6978" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6978"><a href="http://elkintribune.com/formanniversary">Submit Anniversary</a></li>
<li id="menu-item-6979" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6979"><a href="http://elkintribune.com/formbirth">Submit Birth</a></li>
<li id="menu-item-6980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6980"><a href="http://elkintribune.com/formbirthday">Submit Birthday</a></li>
<li id="menu-item-6981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6981"><a href="http://elkintribune.com/formengagement">Submit Engagement</a></li>
<li id="menu-item-6982" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6982"><a href="http://elkintribune.com/formwedding">Submit Wedding</a></li>
</ul>
</li>
<li id="menu-item-6946" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6946"><a href="http://elkintribune.com/calendar">Calendar</a></li>
<li id="menu-item-6947" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-6947"><a href="http://elkintribune.com/entertainment">Entertainment</a>
<ul class="sub-menu">
<li id="menu-item-6988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6988"><a href="http://elkintribune.com/tvlistings">TV Listings</a></li>
<li id="menu-item-6986" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6986"><a href="http://elkintribune.com/tvsoaps">Soaps</a></li>
<li id="menu-item-6991" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6991"><a href="http://elkintribune.com/tvsports">TV Sports</a></li>
<li id="menu-item-6983" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6983"><a href="http://elkintribune.com/tvgames">Games</a></li>
<li id="menu-item-6984" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6984"><a href="http://elkintribune.com/tvmovies">Movies</a></li>
<li id="menu-item-6987" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6987"><a href="http://elkintribune.com/tvbestbets">TV Best Bets</a></li>
<li id="menu-item-6985" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6985"><a href="http://elkintribune.com/tvqa">Q &#038; A</a></li>
<li id="menu-item-6989" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6989"><a href="http://elkintribune.com/tvnews">TV News</a></li>
<li id="menu-item-6992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6992"><a href="http://elkintribune.com/tvtalk">TV Talk</a></li>
<li id="menu-item-6993" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6993"><a href="http://elkintribune.com/tvvideo">TV Video</a></li>
<li id="menu-item-6990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6990"><a href="http://elkintribune.com/tvsearch">TV Search</a></li>
</ul>
</li>
<li id="menu-item-6948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6948"><a href="http://local.elkintribune.com">Businesses</a></li>
</ul></div>
</nav> 
<div zoomdSearch='{"trigger":"OnClick"}' id="search-icon"></div>
</div>
</header> 
<div id="container">
<div id="content" class="clearfix">
<div id="main" class="col620 clearfix" role="main">
<article id="post-13343" class="post-13343 post type-post status-publish format-standard has-post-thumbnail hentry category-college-sports category-high-school-football">
<header class="entry-header">
<div class="entry-meta">
<span class="sep">Posted on </span><a href="http://elkintribune.com/sports/college-sports/13343/cheek-signs-with-methodist-university" title="1:19 pm" rel="bookmark"><time class="entry-date" datetime="2017-04-24T13:19:47+00:00">April 24, 2017</time></a><span class="byline"> <span class="sep"> by </span> <span class="author vcard"><a class="url fn n" href="http://elkintribune.com/author/englewoodindependent-2" title="View all posts by Elkin Tribune" rel="author">Elkin Tribune</a></span></span> </div> 
<h1 class="entry-title">Cheek signs with Methodist University</h1>
<div class="item-cat">
<span class="cat-links">
<a href="http://elkintribune.com/category/sports/college-sports" rel="tag">College Sports</a>, <a href="http://elkintribune.com/category/sports/high-school-football" rel="tag">High School Football</a> </span>
</div>
<br>
<h2 style="font-family:Roboto;"></h2>
</header> 
<div>
<div style="float:left;">
<b><p>By Kristian Russell - <a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="0e657c7b7d7d6b62624e6d6778677a6f7d636b6a676f206d6163">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></p></b>
</div>
</div>
<br>
<hr style="color: #1c63b7; background-color: #1c63b7; height:2px;"/>
<div class="entry-content post_content">
<div class="col-sm-6 col-md-6" style="float:left; width:300px; padding-right:5px; margin-right:10px; margin-bottom:7px;">
<div class="thumbnail">
<a target="popup" onclick="window.open('http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg','Photo','width=600,height=400')" style="cursor: pointer; cursor: hand;">
<img src="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg" data-toggle="modal" data-target="#myModal">
</a>
<div class="caption">
<p style="font-family: Roboto; font-size:0.75em;">McKinley Cheek was joined at his signing by his sister Lilly Cheek, his dad Marty Cheek, and his mom Leslie Cheek. Cheek&#8217;s brother Garvey Cheek, Elkin Principal Joel Hoyle, Elkin football coach Scott Wood, and Elkin AD Tony Duncan were also present at the signing. </p><br>
<p style="font-family: Roboto; font-size:0.75em;"></p>
</div>
</div>
</div>
<article>
<p>One of Elkin&#8217;s standout football players, McKinley Cheek, signed his national letter of intent to play football for Methodist University starting this Fall. Cheek has played football his whole life and played left tackle while at Elkin.</p>
<p>Methodist University is located in Fayetteville, North Carolina and boasts a football team that held a 3-6 overall record last season, and a 2-4 conference record.</p>
<p>Although the Buckin&#8217; Elks were unable to attain a win in the 2016 season, Cheek&#8217;s determination and attitude on and off the field earned him a spot on the 2017 Methodist University football team.</p>
<style>.neFileBlock{margin-bottom:20px;}.neFileBlock p{margin:0px 0px 0px 0px;}.neFileBlock .neFile{border-bottom:1px dotted #aaa;padding-bottom:5px;padding-top:10px;}.neFileBlock .neCaption{font-size:85%;}</style>
<div class='neFileBlock'>
<div class="neFile"><img class="neImage" src="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg"></p>
<div class="neCaption">McKinley Cheek was joined at his signing by his sister Lilly Cheek, his dad Marty Cheek, and his mom Leslie Cheek. Cheek&#8217;s brother Garvey Cheek, Elkin Principal Joel Hoyle, Elkin football coach Scott Wood, and Elkin AD Tony Duncan were also present at the signing. </div>
</div>
<div class="metaInfo"><photo0>http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC_0134-2.jpg</photo0><caption0>McKinley Cheek was joined at his signing by his sister Lilly Cheek, his dad Marty Cheek, and his mom Leslie Cheek. Cheek&#8217;s brother Garvey Cheek, Elkin Principal Joel Hoyle, Elkin football coach Scott Wood, and Elkin AD Tony Duncan were also present at the signing. </caption0><photoCredit0></photoCredit0></div>
</div>
<div class="metaInfo"><bylineMeta></p>
<p>By Kristian Russell</p>
<p><a class="__cf_email__" href="/cdn-cgi/l/email-protection" data-cfemail="83e8f1f6f0f0e6efefc3e0eaf5eaf7e2f0eee6e7eae2ade0ecee">[email&#160;protected]</a><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></p>
<p></bylineMeta></div>
</article>
 
<div style="clear:both;"></div>
<div class="item-wrap clearfix">
<h1 style="font: 700 24px/50px Roboto,Arial,Helvetica,sans-serif; height: 25px; margin-bottom: 20px; text-transform: uppercase; color:#444444;"><a href="/category/news" style="color:#444444;">RECOMMENDED FOR YOU</a></h1>
<hr/>
<div class="item col300">
<div class="item-cat">
<span class="cat-links" style="background-image: url(/wp-content/themes/civitasmedium/library/images/trans.png); color:#ffffff;">
5:15 am |
<img src="/wp-content/themes/civitasmedium/library/images/commentsmall.png" style="height:10px; padding-top:6px;"> &nbsp; &nbsp; <a href="http://elkintribune.com/news/13299/the-elkin-presbyterian-church-will-hold-an-earth-day-festival-with-education-music-food-fun-for-families#disqus_thread" style="color:#ffffff"></a>
</span>
</div>
<div class="item-content">
<header>
<h2><a href="http://elkintribune.com/news/13299/the-elkin-presbyterian-church-will-hold-an-earth-day-festival-with-education-music-food-fun-for-families" title="The Elkin Presbyterian Church will hold an Earth Day Festival with education, music, food, fun for families" rel="bookmark">The Elkin Presbyterian Church will hold an Earth Day Festival with education, music, food, fun for families</a></h2>
</header>
</div>
<a href="http://elkintribune.com/news/13299/the-elkin-presbyterian-church-will-hold-an-earth-day-festival-with-education-music-food-fun-for-families" title="The Elkin Presbyterian Church will hold an Earth Day Festival with education, music, food, fun for families" rel="bookmark"><img src="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC00721-287x300.jpg" alt="The Elkin Presbyterian Church will hold an Earth Day Festival with education, music, food, fun for families" style="margin-left: auto;
    margin-right: auto; width:235px;"></a>
</div>
<div class="item col300">
<div class="item-cat">
<span class="cat-links" style="background-image: url(/wp-content/themes/civitasmedium/library/images/trans.png); color:#ffffff;">
3:28 pm |
<img src="/wp-content/themes/civitasmedium/library/images/commentsmall.png" style="height:10px; padding-top:6px;"> &nbsp; &nbsp; <a href="http://elkintribune.com/news/13297/video-living-waters-farm-store-holds-grand-opening-with-music-massage-more#disqus_thread" style="color:#ffffff"></a>
</span>
</div>
<div class="item-content">
<header>
<h2><a href="http://elkintribune.com/news/13297/video-living-waters-farm-store-holds-grand-opening-with-music-massage-more" title="VIDEO: Living Waters Farm Store holds grand opening with music, massage, more" rel="bookmark">VIDEO: Living Waters Farm Store holds grand opening with music, massage, more</a></h2>
</header>
</div>
<a href="http://elkintribune.com/news/13297/video-living-waters-farm-store-holds-grand-opening-with-music-massage-more" title="VIDEO: Living Waters Farm Store holds grand opening with music, massage, more" rel="bookmark"><img src="http://elkintribune.com/wp-content/uploads/2017/04/web1_DSC00705-300x154.jpg" alt="VIDEO: Living Waters Farm Store holds grand opening with music, massage, more" style="margin-left: auto;
    margin-right: auto; width:235px;"></a>
</div>
<div class="item col300">
<div class="item-cat">
<span class="cat-links" style="background-image: url(/wp-content/themes/civitasmedium/library/images/trans.png); color:#ffffff;">
3:27 pm |
<img src="/wp-content/themes/civitasmedium/library/images/commentsmall.png" style="height:10px; padding-top:6px;"> &nbsp; &nbsp; <a href="http://elkintribune.com/news/13293/elkin-methodist-and-presbyterian-churches-join-evta-to-improve-trails-on-earth-day#disqus_thread" style="color:#ffffff"></a>
</span>
</div>
<div class="item-content">
<header>
<h2><a href="http://elkintribune.com/news/13293/elkin-methodist-and-presbyterian-churches-join-evta-to-improve-trails-on-earth-day" title="Elkin Methodist and Presbyterian churches join EVTA to improve trails on Earth Day" rel="bookmark">Elkin Methodist and Presbyterian churches join EVTA to improve trails on Earth Day</a></h2>
</header>
</div>
<a href="http://elkintribune.com/news/13293/elkin-methodist-and-presbyterian-churches-join-evta-to-improve-trails-on-earth-day" title="Elkin Methodist and Presbyterian churches join EVTA to improve trails on Earth Day" rel="bookmark"><img src="http://elkintribune.com/wp-content/uploads/2017/04/web1_WorkDay25Feb17-4--300x170.jpg" alt="Elkin Methodist and Presbyterian churches join EVTA to improve trails on Earth Day" style="margin-left: auto;
    margin-right: auto; width:235px;"></a>
</div>
</div>
 
<div id="disqus_thread"></div>
<script type="text/javascript">
					var disqus_shortname = 'elkintribune';
					(function() {
						var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
						dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
						(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
					})();
				</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<a href="http://disqus.com" class="dsq-brlink">comments powered by <span class="logo-disqus">Disqus</span></a>
</div> 
<footer class="entry-meta">
Bookmark the <a href="http://elkintribune.com/sports/college-sports/13343/cheek-signs-with-methodist-university" title="Permalink to Cheek signs with Methodist University" rel="bookmark">permalink</a>.
</footer> 
</article> 
<nav id="nav-below">
<h1 class="assistive-text section-heading">Post navigation</h1>
<div class="nav-previous"><a href="http://elkintribune.com/sports/high-school-baseball/13341/buckin-elks-take-mvac-win-over-cardinals" rel="prev"><span class="meta-nav">Previous</span></a></div>
</nav> 
</div>  
<div id="sidebar" class="widget-area col300" role="complementary">
<aside id="weather" class="widget">
<a href="http://www.accuweather.com/en/us/elkin-nc/28621/weather-forecast/2228276" class="aw-widget-legal">
 
</a><div id="awcc1464900698073" class="aw-widget-current" data-locationkey="2228276" data-unit="f" data-language="en-us" data-useip="false" data-partner="civitas" data-uid="awcc1460129762895" data-targeturl="http://elkintribune.com/weather"></div><script type="text/javascript" src="http://oap.accuweather.com/launch.js"></script>
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419632" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419632&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419632&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
</aside>
<aside id="mr1" class="widget">
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419634" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419634&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419634&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
</aside>
<aside id="poll">
<h2 class="widget-title">&nbsp; Poll</a></h2>
<script type="text/javascript">
									if (!window.OX_ads) { 
										OX_ads = []; 
									}
									OX_ads.push({ 
										"auid" : "" 
									});
								</script>
<script type="text/javascript">
									document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
								</script>
<noscript>
<iframe id="510ad285d23d4" name="510ad285d23d4" src="//civitas-d.openx.net/w/1.0/afr?auid=&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510ad285d23d4&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=&cs=510ad285d23d4&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
<script type="text/javascript" src="https://www.civicscience.com/widget/jspoll/?elt=5960044f-3df5-65f4-e5e1-4f62f556fd0c&amp;tgtid=33dc7497-e113-b314-0d0a-263788881010"></script>
<div id="5960044f-3df5-65f4-e5e1-4f62f556fd0c"></div>
</aside>
 
<div id="social-media" class="clearfix">
</div>
<aside id="nationalvideo">
<h2 class="widget-title">National Video</h2>
<div class="ndn_embed" data-config-widget-id="32806" data-config-type="VideoLauncher/Slider300x250" data-config-tracking-group="93004"></div>
<script type="text/javascript">var _ndnq = _ndnq || []; _ndnq.push(['embed']);</script>
</aside>
<aside id="mr2" class="widget">
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419635" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419635&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419635&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
</aside>
<br><br>
<aside id="mr3" class="widget">
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419636" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419636&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="300" height="250">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419636&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
</aside>
<aside id="mr4" class="widget">
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419637" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
</aside>
</div> 
</div>  
</div> 
</div> 
<div id="538148287_INSERT_SLOT_ID_HERE" style="width:640px;height:480px;margin:0;padding:0">
<noscript></noscript>
</div>
<script async type="text/javascript">
		  var OX_ads = OX_ads || [];
		  OX_ads.push({
			 slot_id: "538148287_INSERT_SLOT_ID_HERE",
			 auid: "538148287"
		  });
		</script>
<script type="text/javascript">
				/* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
				var disqus_shortname = 'elkintribune'; // required: replace example with your forum shortname
				/* * * DON'T EDIT BELOW THIS LINE * * */
				(function () {
				var s = document.createElement('script'); s.async = true;
				s.type = 'text/javascript';
				s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
				(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
				}());
			</script>
<style>.footer-add{position:fixed;width:100%;bottom:0;min-width:906px;float:left;background-color:#101010;height:68px;text-align:center;}</style>
<script async type="text/javascript"> 
				if (!window.OX_ads) { 
				OX_ads = []; 
				} 
				OX_ads.push({ "auid" : "419629" }); 
				</script>
<script async type="text/javascript"> 
				document.write('<scr'+'ipt src="//civitas-d.openx.net/w/1.0/jstag"><\/scr'+'ipt>'); 
				</script>
<noscript>
<iframe id="510e960040220" name="510e960040220" src="//civitas-d.openx.net/w/1.0/afr?auid=419629&cb=INSERT_RANDOM_NUMBER_HERE" frameborder="0" scrolling="no" width="1024" height="60">
<a href="//civitas-d.openx.net/w/1.0/rc?cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE"><img src="//civitas-d.openx.net/w/1.0/ai?auid=419629&cs=510e960040220&cb=INSERT_RANDOM_NUMBER_HERE" border="0" alt=""></a>
</iframe>
</noscript>
<footer id="colophon" role="contentinfo" style="height:300px;">
<div class="item-wrap clearfix">
<style>.section{clear:both;padding:0px;margin:0px;}.col{display:block;float:left;margin:1% 0 1% 1.6%;}.col:first-child{margin-left:0;}.group:before,.group:after{content:"";display:table;}.group:after{clear:both;}.group{zoom:1;}.span_5_of_5{width:100%;}.span_4_of_5{width:79.68%;}.span_3_of_5{width:59.36%;}.span_2_of_5{width:39.04%;}.span_1_of_5{width:18.72%;}@media only screen and (max-width: 480px) {.col{margin:1% 0 1% 0%;}.span_1_of_5,.span_2_of_5,.span_3_of_5,.span_4_of_5,.span_5_of_5{width:100%;}}</style>
<div class="section group">
<div class="col span_1_of_5">
</div>
<div class="col span_1_of_5">
<a href="http://civitasmedia.com" style="color:#fff; font-family:Roboto; text-decoration:none;" target="_blank"><img src="/images/civitasreverse.png" style="width:150px;"></a><br>
<a href="http://civitasmedia.com/privacy" target="_blank" style="color:white; font-family:Roboto; text-decoration:none;">Privacy Policy</a><br>
<a href="http://civitasmedia.com/terms" target="_blank" style="color:white; font-family:Roboto; text-decoration:none;">Terms of Service</a><br>
<a href="/advertise" style="color:white; font-family:Roboto; text-decoration:none;">Advertise With Us</a><br>
</div>
<div class="col span_1_of_5">
<a href="http://elkintribune.mycapture.com/" target="_blank" style="color:white; font-family:Roboto; text-decoration:none;">Photo Store</a><br>
<p><a href="http://local.elkintribune.com" target="_blank" style="color:#fff; font-family:Roboto; text-decoration:none;" title="Local Business Directory">Local Business Directory</a></p>
<span style="color:#fff; font-family:Roboto; text-decoration:none;">&copy; 2017 Civitas Media</span><br>
</div>
<div class="col span_1_of_5">
<style>.button{background-color:#008CBA;border:none;color:white;padding:15px 32px;text-align:center;text-decoration:none;display:inline-block;font-size:16px;margin:4px 2px;cursor:pointer;}</style>
<a href="https://www.facebook.com/pages/The-Elkin-Tribune/121619696858" target="blank" title="Elkin Tribune on Facebook"><img src="/wp-content/themes/civitasmedium/library/images/fb.png" alt="Elkin Tribune on Facebook"></a>&nbsp;
<a href="http://twitter.com/ElkinTribune" target="blank" title="Elkin Tribune on Twitter"><img src="/wp-content/themes/civitasmedium/library/images/tw.png" alt="Elkin Tribune on Twitter"></a>&nbsp;
<br>
<a href="/sign-up-for-notices" alt="Sign Up For Notices"><button class="button">Get News Alerts</button></a><br>
<p><a href="tel:336-835-1513" style="font-family:Roboto; color:#fff; text-decoration:none;"><img src="/wp-content/themes/civitasmedium/library/images/footerphonewhite.png" alt="Phone" style="height:15px;"> 336-835-1513</a></p>
<p><a href="tel:336-835-8742" style="font-family:Roboto; color:#fff; text-decoration:none;"><img src="/wp-content/themes/civitasmedium/library/images/footerfaxwhite.png" alt="Fax"> 336-835-8742</a></p>
<p style="font-family:Roboto; color:#fff;"><img src="/wp-content/themes/civitasmedium/library/images/footeraddresswhite.png" alt="Address">214 E. Main Street, Elkin, NC 28621,</p>
<p style="font-family:Roboto; color:#fff;">Elkin NC, 28621</p>
</div>
<div class="col span_1_of_5">
</div>
</div>
</div>
</footer> 
<div id="dpsp-floating-sidebar" class=" dpsp-position-left dpsp-shape-rectangular  dpsp-show-on-mobile dpsp-button-style-1 dpsp-has-button-background "><ul class="dpsp-networks-btns-wrapper dpsp-networks-btns-sidebar"><li><a rel="nofollow" href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Felkintribune.com%2Fsports%2Fcollege-sports%2F13343%2Fcheek-signs-with-methodist-university&t=Cheek+signs+with+Methodist+University" class="dpsp-network-btn dpsp-facebook dpsp-no-label dpsp-first"><span class="dpsp-network-label-wrapper"></span></a></li><li><a rel="nofollow" href="https://twitter.com/intent/tweet?text=Cheek+signs+with+Methodist+University&url=http%3A%2F%2Felkintribune.com%2Fsports%2Fcollege-sports%2F13343%2Fcheek-signs-with-methodist-university" class="dpsp-network-btn dpsp-twitter dpsp-no-label"><span class="dpsp-network-label-wrapper"></span></a></li><li><a rel="nofollow" href="https://plus.google.com/share?url=http%3A%2F%2Felkintribune.com%2Fsports%2Fcollege-sports%2F13343%2Fcheek-signs-with-methodist-university" class="dpsp-network-btn dpsp-google-plus dpsp-no-label"><span class="dpsp-network-label-wrapper"></span></a></li><li><a rel="nofollow" href="#" class="dpsp-network-btn dpsp-pinterest dpsp-no-label dpsp-last"><span class="dpsp-network-label-wrapper"></span></a></li></ul></div><script type='text/javascript' src='http://elkintribune.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
</body>
</html>